wxDev.fr, le portail francophone consacré à wxWidgets ! ( The french portal for wxWidgets )  
Esp. membre
Recheche rapide



Recherche avancée
Statistiques
Membres inscrits :2359

Membres en ligne : 0
Invités en ligne : 2
Pub hébergeur
Pourquoi cette pub ?

Valid XHTML 1.0 Transitional

Valid CSS2

Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Compilation - Installation - Réglages IDE
» wxWidgets + Eclipse
Conversation : wxWidgets + Eclipse
09-12-2011 17:50:43  wxWidgets + Eclipse #1
Behemoth (Nouveau membre)
Inscrit le : 09-12-2011
Messages: 1
Snippets: 0
Tutoriels: 0
Hors ligne
Bonjour,
est-qu'il y a un tutoriel pour installer wxWidgets avec Eclipse?
27-12-2011 12:00:11  Re: wxWidgets + Eclipse #2
Xaviou (Administrateur)
Lieu: Annecy (74)
Inscrit le : 27-08-2007
Messages: 1368
Snippets: 25
Tutoriels: 6
Site web
Hors ligne
Salut, et désolé de ne pas avoir répondu plus tôt.

As-tu trouvé quelque chose?
Sinon, ça ne doit pas être trop compliqué : il suffit d'appliquer les réglages "classiques" (includes, defines, ...)

@+
Xav'

Le nouveau portail wxWidgets francophone : www.wxdev.fr
Ben en fait, vous y êtes déjà...
04-04-2012 16:35:00  Re: wxWidgets + Eclipse #3
vodoomoth (Membre)
Inscrit le : 25-02-2011
Messages: 10
Snippets: 0
Tutoriels: 0
Hors ligne
Salut,
je rebondis sur ce topic parce que j'ai un paquet d'erreurs de compilation "undefined reference to..." sur la compilation du fichier exemple (celui nommé "minimal") fourni dans wxWidgets 2.9.3. J'ai pourtant indiqué la lib wx dans la section "Linker" des paramètres du projet. J'avais auparavant compilée la librairie en statique et en unicode.

En fait, même des fonctions de wxFrame ou wxWindow ne sont pas trouvées.

Je me demande s'il n'y a pas des symboles, explicités nulle part, qu'il faut rajouter quand on builde un projet wxWidegts avec Eclipse et GCC ?

Ou alors, ce serait un problème d'export de la librairie compilée ? L'export des classes et fonctions ne devrait-il pas se faire automatiquement ?

Et je crois qu'un tutoriel aurait effectivement été bienvenu de la part du groupe qui développe wx. D'autant que dans mon cas cela n'a pas suffi d'appliquer les réglages classiques.

EDIT: je viens de trouver http://wiki.wxwidgets.org/Eclipse,_CDT_ … etup_Guide mais ça traite d'Eclipse 3.3… sachat que la 3.7 est la version actuelle et que la prochaine sortirait en juin. J'en reviens pas de la quantité de symboles et d'étapes qu'il faut mettre. N'empêche, cette fois, je ne passe pas la compilation.

EDIT2: je commence par désespérer parce que je n'ai aucun problème à utiliser les autres librairies que j'ai compilées from scratch (libmusicxml2, libMD5, libogg, etc) dans un projet Eclipse. Il n'y a qu'avec wxWidgets que j'ai une tripotée de "undefined reference". J'ai donc utilisé objdump et nm sur les fichiers lib wx... que j'ai compilés:
* avec DEBUG=0, "nm libwxexpat.a" (ainsi que sur tous les libwx…) me sort

Code:

nm: wxexpat_xmlparse.o: File format not recognized
nm: wxexpat_xmlrole.o: File format not recognized
nm: wxexpat_xmltok.o: File format not recognized

* avec des libs compilées avec DEBUG=1, "nm libexpatd.a" me sort un log relativement long.

Je me demande donc si le problème ne viendrait pas de la compilation des librairies qui ferait qqch à la table des symboles.

Enfin, est-ce nécessaire d'utiliser MSYS lorsqu'on travaille avec TDM-GCC et Eclipse ? Merci.

Dernière modification par vodoomoth (06-04-2012 12:33:29)

Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Compilation - Installation - Réglages IDE
» wxWidgets + Eclipse