wxDev.fr, le portail francophone consacré à wxWidgets ! ( The french portal for wxWidgets )  
Esp. membre
Recheche rapide



Recherche avancée
Statistiques
Membres inscrits :2359

Membres en ligne : 0
Invités en ligne : 1

Valid XHTML 1.0 Transitional

Valid CSS2

Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Développement C/C++
» Un bug de wxWidgets ?
Conversation : Un bug de wxWidgets ?
27-01-2010 21:40:32  Un bug de wxWidgets ? #1
congelli501 (Membre)
Inscrit le : 08-06-2008
Messages: 46
Snippets: 0
Tutoriels: 0
Site web
Hors ligne
Bonjour,
Comme dit dans le titre, il y a apparement un bug dans wxWidgets.
Conditions :
Être sous wxGTK (?)
Créer un wxChoice, avec pour style wxCB_SORT ==> classement automatique.
Ajouter des items au wxChoice, en leur assignant un UserData (pointer) / UserObject qui permet de les identifier.
Tenter d'accéder à certains UserData après le classement, après un événement par exemple, renvoi un pointeur NULL.

Est-ce bien un bug de wxWidgets ?
Si c'est le cas, comment puis-je faire pour identifier mes items classés dans mon wxChoice (mis à part les classer manuellement avant) ?

Merci d'avance !

Mes programmes open sources !
On dit que la Grèce antique beaucoup d'influence sur notre culture... C'est vrai : la chute d'Athènes a eu lieu en 404 avant JC. Ca vous rappelle quelque chose ?
28-01-2010 15:34:54  Re: Un bug de wxWidgets ? #2
Xaviou (Administrateur)
Lieu: Annecy (74)
Inscrit le : 27-08-2007
Messages: 1383
Snippets: 25
Tutoriels: 6
Site web
Hors ligne
C'est bizarre, mais cette histoire de problème de tri avec les "userdata" me dit quelquechose... :/

Faudra que je teste ça dès que possible, pour voir.

En tout cas, merci pour l'info, ça peut éviter de se prendre la tête pendant des heures pour chercher un bug...

@+
Xav'

Le nouveau portail wxWidgets francophone : www.wxdev.fr
Ben en fait, vous y êtes déjà...
Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Développement C/C++
» Un bug de wxWidgets ?