wxDev.fr, le portail francophone consacré à wxWidgets ! ( The french portal for wxWidgets )  
Esp. membre
Recheche rapide



Recherche avancée
Statistiques
Membres inscrits :2359

Membres en ligne : 0
Invités en ligne : 4
Pub hébergeur
Pourquoi cette pub ?

Valid XHTML 1.0 Transitional

Valid CSS2

Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Compilation - Installation - Réglages IDE
» Paramétrage de wxDevCpp 7.4
Conversation : Paramétrage de wxDevCpp 7.4
23-10-2012 15:24:50  Paramétrage de wxDevCpp 7.4 #1
Alfred83 (Membre)
Lieu: Toulon 83
Inscrit le : 28-12-2007
Messages: 40
Snippets: 0
Tutoriels: 0
Hors ligne
Bonjour,
Après de multiples essais de changement de version de wxCpp 7.3 vers 7.4 je n'arrive pas à paramétrer celle-ci correctement.
J'ai suivi les instructions (http://wxdsgn.svn.sourceforge.net/viewv … arted.html). J'ai ajouté "Option du designer" "Code Génération options" "wxT".
Lors de l'installation les paramètres du compilateur se sont correctement installés, Le path n'indique aucun chemin qui pourrait porter à confusion, les variables d'environnement idem. Avant l'installation j'ai désinstallé mingw  et supprimé tout répertoire contenant wxWigets.
Les options de mon projet sont inchangées et devraient être bonnes.

Lorsque j'essaie "Tout reconstruire" j'obtiens une série d'erreurs sur toutes les lignes contenant: "wxT (chaine)":
- illegal byte sequence
- variable LXXX, LYYY... non déclarées, alors que mes variables sont XXX, YYY... (pas de L en tête).
Entre autres:
SetContracte( wxT("Inchangé") ); --> errreur "invalid argument".
Ailleurs "wxOpen non déclaré".

Dernière modification par Alfred83 (24-10-2012 22:49:24)


Informaticien bénévole du "Groupement des Intellectuels Aveugles ou Amblyopes" à Toulon, qui publie les trois quarts des livres en braille en France.
26-10-2012 10:49:03  Re: Paramétrage de wxDevCpp 7.4 #2
Xaviou (Administrateur)
Lieu: Annecy (74)
Inscrit le : 27-08-2007
Messages: 1365
Snippets: 25
Tutoriels: 6
Site web
Hors ligne
Salut, et désolé d'avoir mis autant de temps à répondre.

Je serais tenté de dire qu'il y a un problème de compatibilité entre les options wxWidgets (Unicode) et les fichiers sources (encodées en Ansi).

Je n'ai pas wxDevCpp, je ne peux donc pas tester, mais tu peux le faire toi : supprime le caractère accentué pour voir ce que ça donne.

En ce qui concerne wxOpen, je ne sais pas où tu l'as trouvé, mais cette fonction n'a pas l'air d'exister dans les libs, que ce soit en version 2.8.12 ou 2.9.4.

@+
Xav'

Le nouveau portail wxWidgets francophone : www.wxdev.fr
Ben en fait, vous y êtes déjà...
Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Compilation - Installation - Réglages IDE
» Paramétrage de wxDevCpp 7.4