wxDev.fr, le portail francophone consacré à wxWidgets ! ( The french portal for wxWidgets )  
Esp. membre
Recheche rapide



Recherche avancée
Statistiques
Membres inscrits :2359

Membres en ligne : 0
Invités en ligne : 1

Valid XHTML 1.0 Transitional

Valid CSS2

Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Développement C/C++
» Problème compilation
Conversation : Problème compilation
03-06-2009 10:34:04  Problème compilation #1
aion_player (Nouveau membre)
Inscrit le : 18-05-2009
Messages: 2
Snippets: 0
Tutoriels: 0
Hors ligne
Bonjour à tous,

Je vous expose mon problème:

On m'a donné un programme développé avec wxWidgets et que j'ai réussi à débugger avec DevC++ (même s'il m'ouvre une fenetre m'indiquant
Can't load bitmap 'wxBITMAP_STD_COLOURS' from resources! check .rc file.
).
Cependant, je dois maintenant continuer à développer en utilisant ce programme mais sous visual studio. Et quand j'essaie de compiler ce même programme, il survient cette erreur:
error C2679: binary '=' : no operator found which takes a right-hand operand of type 'wxImage *' (or there is no acceptable conversion)
c:\wxwidgets-2.8.10\include\wx\image.h(429): could be 'wxImage &wxImage::operator =(const wxImage &)'
while trying to match the argument list '(wxImage, wxImage *)'
Je ne comprends pas pourquoi ca marcherait avec DevC++ et pas avec visual studio, et je suis débutant avec wxWidgets donc c'est chaud de débugger!!!

Merci pour votre aide.
Menu forum (navigation):
Pages: 1  
 
Accueil » Accueil forums » Développement C/C++
» Problème compilation